
Open

Click on the File menu, then Open (or use the Open tool on the toolbar.) A dialog allows you to open a file
for use in IrfanView.
 
Use the Look in box to locate the file you want, or type a file name into File Name. Files of type lets you 
limit your choice, showing only the type of file you want (JPG, for instance.) The default is Common 
IrfanView Files (Windows can't display at same time all file types supported by IrfanView).
 
If you check Preview active, a single click on an image filename will display a small version. Another click
brings the file into the viewer. You can also double click the filename.
 
If multiple images are in the file, as with icons, a small dialog box will allow you to choose one. Single 
click the names for a preview. Click accept when you find the one you want.
 
To close without opening a file, click Cancel .  Another way to close is to click the X    in the upper right 
corner.

After the opening, you will see an image or you will get an error message, if the file type is unsupported 
by IrfanView.

If you open a large image, you can use scrollbars to see all parts of the image. Scrolling is possible with 
the arrow keys and with the page up/down, home/end keys. Scrolling is also possible with the right mouse
button: press the right mouse button and move the mouse arround. 

See also:
          Reopen
          Open with external editor



Thumbnails

Open an image from a selected directory in the viewer. Click the File menu, then Thumbnails. A box will 
open and fill with thumbnails of the images in the directory.

On the left side is a tree view with drives and directories. 

Double click any thumbnail to open that image in the viewer. If you change directories by opening another
image, the thumbnail display will show those images.
 
To close the display, click Exit on the display's menu bar or press ESC.
 

File:

Copy selected files: allows you to copy all selected thumbs (files) to another directory. 

Move selected files: allows you to move all selected thumbs (files) to another directory. 

Delete selected files: allows you to delete all selected thumbs (files). 

Start slideshow with selected thumbs: Click to start slideshow with all selected thumbs (files) and 
current slideshow settings. 

Create contact sheet: allows you to create a large image (contact sheet or catalog) with all selected 
thumbs (files). A dialog appears and you can choose the options for the result image.

Save selected thumbs as an image. Click to have your selected thumbs made into a single image and 
saved.    A dialog lets you choose the directory to save the image in. Images are selected by clicking on 
each thumb, while holding down the CTRL key, or by using the Select All option (see above.)

Save selected thumbs as HTML file. Click to make a page of thumbs that can be used in a web 
browser, or at an internet website. A dialog lets you choose some HTML options and the directory to save 
the file in. Images are selected by clicking on each thumb, while holding down the CTRL key, or by using 
the Select All option (see above.) 

Save selected thumbs as single images. Click to have chosen thumbs made into images and saved 
individually. A dialog lets you choose the directory to save them in. Images are selected by clicking on 
each thumb, while holding down the CTRL key, or by using the Select All option (see above.)

Print selected thumbs as single images. Click to print all selected images (batch printing). Images are 
selected by clicking on each thumb, while holding down the CTRL key, or by using the Select All option 
(see above.)

Send selected thumbs by EMail. Click to send all selected images by EMail (PlugIn required). Images 
are selected by clicking on each thumb, while holding down the CTRL key, or by using the Select All 
option (see above.)

Open with external editor. Click to have an alternate viewing or editing program opened, with the image 
connected to the current thumbnail displayed in it. To use this option, you must first set up an external 



editor.

Options:

Save current size/postion will save the actual size/position of the Thumbnail window. You can 
resize/move the Thumbnail window manually with mouse.

Select All highlights all the thumbs for saving them as files (below.)

Set thumbnail options lets you control the size and quality of the thumbnails. Click it to open a dialog 
box. The first option is Use Resample instead of Resize for creating thumbnails. Click the check-box 
to have better quality thumbnails displayed. This may take longer for the images to appear. The next 
option is Thumbnail size. Click one of the option buttons to set a size for the thumbnails. The default is 
80 x    80 pixels. 

You can also set the color/border options for thumbnails and the background color for the thumbnail 
window.

You can Set the number of the MRUDs. If you want to clear the MRUD list, press the Clear MRUDs 
button.
When done making your choices, click OK to exit. Click Cancel  to exit without making any changes.

View:

Directory tree will hide/show the directory tree on the left side of thumbnail window.
Most recently used directories will hide/show the box    with last used directories on the top side of 
thumbnail window.



Slideshow

Click on the File menu, select Slideshow. A dialog allows you to select a directory from which the files will
be taken. Use Look in and File name to narrow the search; use Files of type to limit the search to one 
type of file, such as JPG.

Click the file names you want to use. If you have a range of files to choose, click the first. Move the 
mouse to the last file in the group, hold down the Shift key on the keyboard, and click. To choose 
individual files, hold down the Ctrl    key and click each file name with the mouse. Click the Add button. 
Click the Add all    button to select every image in the directory. Remove and Remove all     take files 
back out.

Click the Advanced    button to choose a sort order by name, date, size, or extension. Files may be sorted
in ascending or descending order. To remove a sort, click the No sort option button. Click Stop 
Slideshow and close IrfanView after the last image if you want to close IrfanView after the slideshow. 
Click OK to close the dialog. To exit without making changes, click the Cancel    button.

There are several options for slideshow. If there is a check-mark in the box, the option is "on." Unchecked
means "off." Click Loop to cause Slideshow to play continuously. The next option is Suppress errors 
during slideshow. Next is Show image filename; click this to display the name of the image as it 
appears on screen. The final option is Hide mouse cursor; click to make the mouse cursor "invisible" 
while the slideshow is playing. The next option is Don't display same image again (if random 
slideshow); no repeats in the random slideshow.

There are settings for how long each image will be shown; click the option button of your choice. The top 
option plays the next image automatically after a number of seconds; type a number into the box to 
change the timing. The second option will cause the viewer to wait until you touch a key on the keyboard 
or move the mouse before displaying the next image. The third option plays a randomly chosen image 
after the specified time; the fourth plays a random image after you touch a key or the mouse.

Click the Play button to begin the slideshow.

Slideshows can be saved for future use. When you choose the images and begin playing a show, 
IrfanView creates a file named:

          Slideshow.lst

which is placed in the IrfanView directory on your disk drive. This may be loaded back into the viewer and
used again. Click Load from TXT file, and a dialog like the Open dialog from the File menu appears. Find
the file you want to use and click Open to load it. Click Save as TXT file, and a dialog like Save As 
appears. Give your slideshow a name, and click Save to have it stored on the disk drive.

Slideshows can be created outside of IrfanView, then loaded once you open the viewer. Use a text editor 
that stores its files as plain text, such as Windows Notepad. The file only contains the name of each 
image to be played in the slideshow, each on a separate line in the file. Each must include the complete 
path where the image will be found on your hard drive. It will look something like this:

          C:\Images\myimage.JPG

Create the file and store it on your disk. When you start IrfanView, open the Slideshow dialog, and use 
the Load from TXT file button to start your show. Shows can also be played from outside the viewer, 



using a Command Line Option.

When you are done click Close. You may also click this before the slideshow starts. Another way to exit is
to click the X in the upper right corner.

How to pause an automatic slideshow? Just press the Pause key. Press the pause key again to restart 
the slideshow.



Batch Conversion/Rename

Click on the File menu, select Batch Conversion/Rename. A dialog allows you to select a directory from 
which the files will be taken. Use Look in,    File name, and Files of type to limit the search.

Select the output directory at bottom right.    If you don't have the full path for this directory, click the 
Browse button to find it. When you have selected a directory with Browse, find a directory and click the 
OK button.

You can set the current directory as output directory if you press the Use this directory as output button.

If you want to include all images from sub-directories, check the Include subdirectories option.

Batch Conversion:
Select the Output Format at bottom left. This works just like Save and Save As. The Options button lets 
you choose various operations to perform, also just like their Save and Save As versions. 

Use the Advanced Options button to apply many special operations to the images during conversion. 
These options are much like their versions on the Image menu. The options are:

Crop, Resize, Change color depth, Horizontal flip, Vertical flip, Rotate left, 
Rotate right, Convert to greyscale, Negative, Sharpen, Gamma 
Correction, Contrast, and Brightness.

Batch Rename:
You can rename original/input files or you can copy/move original files to output directory and rename the 
files in the output directory. For renaming, you can generate a name pattern for new names and the 
starting index for numbers.

Check those you want to use, then click OK. To exit without making any selections, click Cancel.

Select the files you want to convert by clicking their names. For a large range of files: click the first name, 
move the mouse to the last file in the group, hold down the Shift key, and click. To choose individual files, 
hold down the Ctrl    key and click each name.

Click the Add button to add the (selected) files that will be converted. Click the Add all    button to select 
every image in the directory with the extension choosen in Files of type. Remove and Remove all    take 
chosen files back out.

Click the Start button to begin. A box shows the progress of the conversion. If you need to halt, click the 
Stop button. When the process is done, click Exit to close the dialog.

File conversion may also be performed from outside IrfanView, using a Command Line Option.



When you are finished converting files, click Cancel    to exit. Another way of exiting is to click the X in the 
upper right corner.



Rename

Click on the File menu, select Rename File. A dialog opens; type in a new name for the file and click OK. 
The filename will be changed, both in the viewer and on the hard drive (or other source.) To exit without 
making a change, click Cancel .
 
While renaming the file, you can also move it to a new location: type in the full path name of the new 
directory, followed by the name of the image. The name will be changed, and the image will be put in the 
new directory (This may also be done without changing the name; just type in the path with the old name).



Move

Click on the File menu, then Move File. The file in the viewer will be moved to another directory on your 
hard drive (or other media.) 

For this function to work, first set up a default directory for Move.

The Move dialog offer 5 different directories as destinations.

See also:
            Properties: Copy/MoveDelete options



Copy (File menu)

Click on the File menu, select Copy File. The file in the viewer will be copied to another directory on your 
hard drive (or other media.)

 For this function to work, first set up a default directory for Copy.

The Copy dialog offer 5 different directories as destinations.

See also:
            Properties: Copy/MoveDelete options

 



Delete (File Menu)

Click on the File menu, select Delete File. The file in the viewer is removed from your hard drive (or other 
source.) Be sure you want this, as the file is immediately removed.

 If you delete a file by accident, just resave the image.
 
There is also a Delete option on the Edit menu: this only removes the file from the viewer (memory), it 
doesn't affect the file on your hard drive.

See also:
            Properties: Copy/MoveDelete options



Save

Click on the File menu, then Save.
 
Allows you to save your file to disk. Use Save in and File name to find the directory where you want the 
file saved.
 
To save the file as a different type, use Save as type. Click the arrow and a list of file types drops down. 
Move the cursor to the one you want and click again. When you save, the file will be converted to this new
type.
 
Clicking the Options button brings up special options for some file types. There are five tabs: JPEG/GIF, 
LDF,    LWF,    PNM and TIFF
 
Click Save    to send the file to your disk drive. Click Cancel    to exit without saving.
 
Note that Save comes up in the last directory from which you loaded an image; Save As comes up in the 
last directory in which you saved a file.

 
See also:
          Save As



Print

On the File menu, click Print. This will bring up the Windows print dialog, from which you finish printing as 
usual. Remember to check the box for Portrait or Landscape orientation.

A dialog appears with options for printing an image. A preview shows how the image would look printed in 
Portrait or Landscape orientation.
 
Option buttons select how the image will print. Best Fit puts the image on the page as large as it can, 
without altering the dimensions. Stretch to Page fills the print area, even if it has to re-size one dimension.
 
Custom allows you to print the image with specific size. Type in the desired change: width, height and 
left/top margin in cm or inches. 
 
Scale fits the image on the page. Type in the desired change; 1.00 is normal size; 2.00 is twice as large in
that dimension.

Click Center on Page to have the image printed in the center of the paper. 

You can print the file name of the image or its path as head- and/or footnote.

 
Select options, then click Print. 
 
Click Cancel    to exit the Print dialog without printing, or when the job is done.



Select TWAIN Source

Click on the File menu, then Select TWAIN Source. 

Allows you to choose from the scanners, or any other TWAIN compatible device (digital camera, TV card 
etc.), installed on your computer (if more than one is available). 

Click the name of the device you want to use, then the Select button. To exit without making a selection, 
click Cancel .

See also:
          Acquire



Acquire

Click on the File menu, click Acquire. 

The program that runs your scanner, or any other TWAIN compatible device (digital camera, TV card 
etc.), will appear. Follow the steps given in your scanner's manual for scanning an image. 

When finished, the image will be placed into IrfanView.

See also:
          Select TWAIN Source



Exit

There are several ways to exit the program:

On the main window, press the ESC key on your keyboard. The program will close immediately. (If you're 
in any of the menus or dialog boxes, ESC will back out of that window. Press it again to exit.)
 
From the File menu, you can press the E key, to close IrfanView. When using the mouse,    just click the 
EXIT option to close the viewer.
 
Click the logo in the upper left corner of the program window to bring up the standard Windows control 
box. Click the Close option.
 
Click the X    box in the upper right corner of the program window. This will also close the program.
 
Note: IrfanView doesn't ask if you are sure you want to exit - it closes right away. Be sure you've saved 
any work you want to keep.



MRUDs

On the File menu, point the mouse at MRUDs (most recently used directories). A sub-menu appears 
showing the most recently used directories. Click one, and the Open dialog appears, already in the chosen
directory. From there you can open any file in the directory.
 
The MRUDs list can be erased using a button on the Others 1 tab, located in the Properties box, on the 
Options menu.



Reopen

Click on the File menu, select Reopen to bring in, again, the last file you opened.
    
If more than one image is involved, Reopen will let you select from them again.

See also:
          Open
          Open with external editor



Save As

Click on the File menu, select Save As (or use the Save As tool on the toolbar.)
 
Saves your file to disk. Use Save in and File name to find the directory where you want the file saved.
 
To save as a different type, use Save as type. Click the arrow and a list of file types drops down. Move 
the cursor to the one you want and click again. When you save, the file will be converted to this new type. 
 
Clicking the Options button brings up special options for some file types. There are five tabs: JPEG/GIF, 
LDF, LWF,    PNM and TIFF.
 
Click Save to send the file to your disk drive. To exit without saving, click Cancel.
 
Note that Save As comes up in the last directory in which you saved a file. Save comes up in the last 
directory from which you loaded an image

See also:
          Save



Undo

Click on the Edit menu, select Undo (or use the Undo tool on the toolbar.)
 
"Backs up" from the last action you took. Undo will take back many functions of IrfanView. Only one 
function may be undone; the viewer does not save them up. You can disable this option in Others 1 tab in 
the Properties dialog.
 
Functions supported by Undo are: 3-D Button,    Blur, Enhance colors, Convert    to Greyscale,    Crop,    
Cut,    Decrease Color Depth,    Edge Detection,    Emboss,    Explosion,    Fine Rotation, Increase Color 
Depth,    Median Filter,    Negative,    Oil Paint,    Pixelize, Resize/Resample,    Sharpen.



Add Text

Use the left mouse button to outline the area (selection) on the image where you want text to appear. 
Click the Edit menu, then Add Text.    A dialog box will open.

How to make a selection? Just press the left mouse button and move the mouse. You will see the 
selection rectangle. If you click on the image again, the selection rectangle will be deleted and the 
selection is not more active.

In the Text box on the left, type in the text you want to put on the image.
 
Use the Choose Font button to change the size, style, color, etc., of the text. The name of the selected 
font is shown under the Text box.
 
Uncheck the Text is transparent box to choose a background color. The highlighted area will change to 
that color, with the text inside. The small box above the button shows the selected background color.
 
Click the OK button to add the text to your image. To close the dialog without adding any text, click the 
Cancel    button.
 
Add text may be reversed with the Edit menu's    Undo command.



Cut

Use the left mouse button to outline the area (selection), click on the Edit menu, then Cut (or use the Cut 
tool on the toolbar.)

Cut - selection
The area inside the outline will be removed from the image. The cut portion is placed on the Windows 
Clipboard, and may be pasted in elsewhere.

Cut - leave selection
The area outside the outline will be removed from the image.

This action may be reversed with the Edit Menu's Undo command.

See also:
          Paste



Crop

Use the left mouse button to outline the area (selection), click on the Edit menu, then Crop.

The area outside the outline will be thrown away, only the inside will be left.
 
Use this to eliminate unwanted space (usually blank space) from an image. It can also center a badly 
composed photo. 

Use with Resample (Image menu,) to eliminate background "noise", and often have the same sized 
image when you finish.
 
This action may be reversed with the Edit Menu's Undo command.



Copy (Edit menu)

Use the left mouse button to outline the area (selection), click on the Edit menu, select Copy (or use the 
Copy tool on the toolbar.)

The area inside the outline will be placed on the Windows Clipboard, and may be pasted in elsewhere.
 
If you don't select an area with the mouse, the entire image will be copied to the Windows Clipboard.

See also:
          Paste



Paste

Click on the Edit menu, then Paste (or use the Paste tool on the toolbar.) 

If you have an Edit outline around an area of the current image, an image stored on the Windows 
Clipboard will be pasted into your outline. The Clipboard image will be re-sized to fit the outline, and the 
rest of the image will stay as it was. This feature is very useful for editing images or portions of them.

If there is no Edit outline, an image on the Windows Clipboard will replace the entire image in the viewer.

See also:
          Cut
          Copy (Edit menu)



Delete (Edit menu)

Click on the Edit menu, then Delete. 

Removes the entire image from the viewer. This does not affect the image stored on your disk drive.
 
There is also a Delete option on the File menu; this one removes the file from your disk drive completely.



Clear Clipboard

Click on the Edit menu, then Clear Clipboard. 

Removes the contents of the Windows Clipboard. 



File Menu

          The following options are available on the File Menu:

Open
Reopen
Open with external editor
Open in HEX viewer

Thumbnails

Slideshow
Batch Conversion/Rename

Rename
Move
Copy File
Delete File

Save
Save As

Print

Select TWAIN Source
Acquire
Batch Scanning

MRUDs

Exit



Edit Menu

          The following options are available on the Edit Menu:

Undo

Add Text

Cut - selection
Cut - leave selection

Crop

Copy
Paste
Delete

Clear Clipboard



Download/Contacting the Author

The latest edition of IrfanView can be downloaded from the Internet at:

          http://www.irfanview.com

or

        http://www.ryansimmons.com/users/irfanview/

or

          http://members.chello.at/irfan.skiljan/

The author of the program, Irfan Skiljan, can be E-mailed at: 

          irfan@linux.tuwien.ac.at

If you want to register the program with him (only $10 US or DM 20)
send your cash payment to: 

          Irfan Skiljan
          Postfach 6
          2752 Woellersdorf
          Austria, Europe



IrfanView

IrfanView is a compact, easy to use image viewer. More than that, you can also edit images directly in 
IrfanView, to produce a variety of effects. IrfanView was created by Irfan Skiljan.

Open IrfanView by clicking its icon on the Windows Start Menu or double clicking the icon on your 
desktop.
 
Click on the File menu, then the Open option to get a file for use in the viewer. A dialog box will allow you 
to select the file you want. Click the Preview active box in the Open dialog to see small versions of 
images before opening them.
 
With an image in the viewer, you can manipulate it in a large number of ways. Most functions for changing
an image are in the Edit and Image menus.
 
When you are finished with the image, Save it to your disk. Bring in another image, or Exit IrfanView.

Click on the image below to find out more about that function:



Supported File Formats

These are the file formats supported by the current version of IrfanView:

AIF¹,    ANI,    AU¹,    AVI,    BMP,    CAM,    CLP,    CPT,    CUR,    DAT¹,    DCM/ACR, DCX,    DIB,    DJVU, 
EMF,    EPS,    FLI/FLC², FPX, G3, GIF,    ICL,    ICO,    IFF/LBM,    IMG, JPG/JPEG,    KDC, LDF, LWF,    
Mac PICT², MED, MID,    MOV¹²,    MP3, MPG/MPEG¹, NLM/NOL/NGG/NSL/OTB/GSM, PBM,    PCX,    
PGM,    PhotoCD,    PNG,    PPM,    PSD,    PSP,    QTIF², RAS/SUN,    RealAudio, RLE,    RMI,    SFF, 
SFW,    SGI/RGB, SWF, SND¹,    TGA,    TIFF/TIF,    WAV,    WBMP, WMF, XBM, XPM

¹    Microsoft's Media Player program is required for these formats.
²    Apple's QuickTime program is required for these formats.

Note: These formats are used as PlugIns: AVI, MP3, MPG, MID, WAV, SWF (Flash/Shockwave), FPX 
(FlashPix), LWF, LDF, KDC, MED, NLM/NOL/NGG/NSL/OTB/GSM, PCD (Photo CD, large 
resolutions), DJVU, Dicom/ACR, G3, RAS, BioRAD, Mosaic, XBM, XPM, GEM-IMG, SGI, WBMP, RA,
RLE, SFF.

Direct download:

http://www.irfanview.com/plugins.html

IrfanView Formats Overview:

Extension Format name Open Save

AIF Sound file, Audio Interchange Format YES¹³

ANI Animated Cursor format for Microsoft Windows YES

AU, SND Encoded Audio format used by Sun and NeXT machines YES¹³

AVI Audio Video Interleaved: Microsoft's video format for Windows YES

BMP, DIB Windows Bitmap YES YES

CAM Casio digital camera file YES (JPG version)

CLP Windows clipboard format YES



CPT CorelDraw Photopaint image YES (CPT version 6)

CUR Cursor Resource file format for Microsoft Windows YES

DAT Video CD format YES¹³

DCM, ACR Dicom/ACR file format for medical images YES³

DCX Multipage PCX files format YES

DJVU, IW44 DejaVu format from AT&T YES³

EMF Enhanced Metafile Format YES YES

EPS Encapsulated PostScript YES (TIF preview)

FLI, FLC Autodesk animation format YES² ³

FPX FlashPix format YES³

G3 Group 3 Facsimile Apparatus format YES³

GIF Graphics Interchange Format YES YES

ICL, EXE, DLL Icon Library formats YES (icons)

ICO Windows Icon YES YES

IFF, LBM Interchange File Format YES

IMG GEM Raster image YES³

JPG, JPEG Joint Photographic Experts Group YES YES

KDC Kodak digital camera format YES³

LDF LuraDocument Format YES³ YES³

LWF LuraWave Format YES³ YES³

Mac PICT Macintosh PICT format YES² ³

MED MED/OctaMED sound format YES³

MID, RMI Musical Instrument Digital Interface (MIDI) YES³

MOV QuickTime Movie format YES² ³

MP3 MPEG audio layer 3 format YES³

MPG, MPEG Moving Pictures Experts Group format YES¹³



NLM/NOL/NGG/OTB/GSM Nokia/LogoManager files YES³

PBM Portable Bitmap File format YES YES

PCX PC Paintbrush format from ZSoft Corporation YES YES

PCD Kodak Photo CD YES

PGM Portable Greymap File format YES YES

PNG Portable Network Graphics YES YES

PPM Portable Pixelmap format YES YES

PSD Adobe PhotoShop format YES

PSP Paint Shop Pro file format YES

QTIF QuickTime format YES² ³

RAS, SUN Sun Raster format YES³

RA Real Audio sound format YES³

RLE Utah RLE format YES³

SFF Structured Fax File YES³

SFW Seattle Film Works format YES³

SGI, RGB, RGBA Silicon Graphics format YES³

SWF Macromedia's Flash/Shockwave format YES³

TGA Truevision Advanced Raster Graphics Adapter (TARGA) YES YES

TIF, TIFF Tagged Image File Format YES YES

WAV Windows audio file YES³

WBMP WAP Bitmap format YES³

WMF Windows Metafile format YES

XBM X11 Bitmap YES³

XPM X11 Pixmap YES³

¹    Microsoft's Active Movie program is required for these formats.
²    Apple's QuickTime program is required for these formats.



³    PlugIn is required for these formats, see above for download.



Image Menu

          The following options are available on the Image Menu:

Information

Create new image

Rotate Left
Rotate Right
Vertical Flip
Horizontal Flip

Resize/Resample

Count colors used
Increase Color Depth
Decrease Color Depth

Convert to Greyscale
Negative
Enhance colors

Sharpen
Effects

Swap Colors
Palette



Information

Click on the Image menu, then Information (or use the Information tool on the toolbar.) A box opens with 
the following about the image:
 

File name
Directory name

            Copmression method (and DPIs if available)
Original size (Width/Height in pixels)
Current size (Width/Height in pixels)
Original colors (color depth, BitsPerPixel)
Current Colors (color depth, BitsPerPixel)
File disk size (in KB)
Image memory size (in KB, decompressed)
Current directory index
File date/time
Loaded in (time to load image)

If you load a JPG image with EXIF information, the button 'EXIFinfo' is visible and IrfanView shows you 
EXIF information.

When you are viewing a photo in JPG format with Exif photo information, click on Image Information and 
an IrfanView Image Properties window opens, in the lower left hand corner you will see button marked 
"EXIF info", click on the button and another window will open to display all the exposure information 
pertaining to the photo you are viewing. 
Click your mouse on the name of the file and use your cursor up and down keys to scroll through the 
information. You will find the date, time,    image size, lens aperture opening, zoom lens setting, quality 
mode, shutter speed, use of flash, ISO speed of CCD setting sensitivity, make and model of camera. This 
information is in text (.txt) format. You can select the text info copy it to clipboard so that you can paste it 
into a word processing program so you can print it or save into the same directory where your photo 
images are stored for future reference.

Note: EXIF component is stored in the EXIF-plugin, please install!

If you load a JPG image with IPTC information, the button 'IPTC info' is visible and IrfanView shows you 
IPTC information.

Note: IPTC component is stored in the IPTC-plugin, please install!

If you load a JPG image with comment information, the button 'JPG Comment' is visible and IrfanView 
shows you the comment.

When you are viewing a photo in JPG, GIF, PNG format with NCC (www.netcybercards.com) photo 
information, click on Image Information and an IrfanView Image Properties window opens, in the lower 
right hand corner you will see button marked "NCC info", click on the button and another window will open
to display all the exposure information pertaining to the photo you are viewing. 

Note: NCC component is stored in the NCC-plugin, please install!



Click the OK button when you are done viewing the information.



Rotate Left

Click on the Image menu, then Rotate Left.    The image will turn 90 degrees; the top of the image will 
move towards the left.

See also:
          Rotate Right
          Vertical Flip
          Horizontal Flip
          FineRotation



Rotate Right

Click on the Image menu, then Rotate Right.    The image will turn 90 degrees; the top of the image will 
move towards the right.

See also:
          Rotate Left
          Vertical Flip
          Horizontal Flip
          FineRotation



Vertical Flip

Click on the Image menu, then Vertical Flip. The image will turn upside-down. The left/right orientation 
will stay the same.

See also:
          Horizontal Flip
          Rotate Left
          Rotate Right
          Fine Rotation



Horizontal Flip

Click on the Image menu, then Horizontal Flip. The image will turn side-to-side, as in a mirror.

See also:
          Vertical Flip
          Rotate Left
          Rotate Right
          Fine Rotation



Resize/Resample

Click on the Image Menu, then Resize/Resample. A dialog allows you to choose the new size for the 
image; some Resample filter can be used if you are enlarging the image. 

There are several built in choices, or you can type over the old numbers. The first number is width, the 
second height, both in pixels. Leave the Preserve aspect ratio box checked, type in one number and the
other will be calculated for you.
 
Resampling an image often improves its quality, especially when enlarging it. Enlarging without 
resampling can result in a blurry image.

Click OK to resize the image. This action can be reversed by the Edit menu's Undo command.

See also:
          Image Menu



Increase Color Depth

Click on the Image menu, then select Increase Color Depth.    A dialog shows the possible color depths. 
Select one.
 
Click OK to make the change. This action can be reversed by the Edit menu's Undo command.

See also:
          Decrease Color Depth



Decrease Color Depth

Click on the Image menu, then select Decrease Color Depth.    A dialog shows the possible color depths. 
Select one.
 
Click OK to make the change. This action can be reversed by the Edit menu's Undo command.

See also:
          Increase Color Depth



Convert to Greyscale

Click on the Image menu, then select Convert to Greyscale.
 
Greyscale (or grayscale) is actually a color mode, like RGB. It contains more information about the photo 
than Black and White. Converting from color to greyscale will usually give a better effect than from color 
to black and white.
 
This action can be reversed by the Edit menu's Undo command.



Negative

Click on the Image menu, then select Negative. The image is converted to a reversed color version of the
original.
 
This action can be reversed by the Edit menu's Undo command.



Enhance colors

Click on the Image menu, then Enhance colors. A dialog appears with a slider controls. Move the setting 
up or down, for more or less brightness / contrast / gamma / RGB. 

You'll see the image change as you move the control. When you are satisfied, click OK. To quit without 
changing the image, click Cancel.
 
This action can be reversed by the Edit menu's Undo command.



Sharpen

Click on the Image menu, then Sharpen. The sharpness of the image can be set using Effects setup.
 
This action can be reversed by the Edit menu's Undo command.



Effects

Click on the Image Menu, then point the mouse at Effects to access these options.
 
Note: All of these effects (except Filter Factory) can be used on a smaller portion (selection) of an image, 
as well as the entire image.
 

The Effects possible are:
 
3D Button
Click on the Image Menu, point the mouse at Effects, and click 3D Button. 

Gives the image a beveled edge look, with the center raised. The size of the border can be changed 
using Effects setup.
 
This action can be reversed with the Edit menu's Undo command.
 
 
Blur
Click on the Image Menu, point the mouse at Effects, and click Blur. 
 
Softens the image, creating a blurry or fuzzy look. The amount of blur can be changed using Effects 
setup.
 
This action can be reversed with the Edit menu's Undo command.
 
 
Emboss
Click on the Image Menu, point the mouse at Effects, and click Emboss.
 
Turns the background grey and gives the image an engraved appearance.
 
This action can be reversed with the Edit menu's Undo command.
 
 
Oil Paint
Click on the Image Menu, point the mouse at Effects, and click Oil Paint. 
 
Creates a textured effect, such as that seen in an oil painting. The amount of texture can be changed 
using Effects setup.
 
This action can be reversed with the Edit menu's Undo command.
 
 
Edge Detection
Click on the Image Menu, point the mouse at Effects, and click Edge Detection.
 
Finds the main lines in an image and replaces their color with the opposite color, at the same time most fill
colors are darkened, making them like a background. The image takes on a "painted on velvet" 
appearance. This effect needs a color depth of 256 or less to work properly.
 



This action can be reversed with the Edit menu's Undo command.
 
 
Median Filter
Click on the Image Menu, point the mouse at Effects, and click Median Filter.
 
Causes a group of pixels to have the brightness of the "average" pixel in that group. In most cases, this 
has a "smoothing" effect on the area being filtered. The amount of filter can be changed using Effects 
setup.
 
This action can be reversed with the Edit menu's Undo command.
 
 
Explosion
Click on the Image Menu, point the mouse at Effects, and click Explosion.
 
Breaks up the image, as if the darker pixels exploded. The amount of Explosion can be changed using 
Effects setup.
 
This action can be reversed with the Edit menu's Undo command.
 
 
Pixelize
Click on the Image Menu, point the mouse at Effects, and click Pixelize.
 
Breaks the image into a coarse version of itself, as if it were made up of oversized pixels. The amount can
be changed using Effects setup.
 
This action can be reversed with the Edit menu's Undo command.
 
 
Fine Rotation
Click on the Image Menu, point the mouse at Effects, and click Fine Rotation.
 
Turns the image to the left or right. The degree of rotation can be changed using Effects setup.
 
          See also:  Rotate Left,    Rotate Right.
 
This action can be reversed with the Edit menu's Undo command.

Other menu options:
 
Setup
Click on the Image Menu, then click Setup. Opens a dialog from which you can change many of the 
Effects settings.
 
 
Filter Factory
Click on the Image Menu, then click Filter Factory. Opens a dialog from which you can perform many 
other Effects. 

Filters Unlimited
Click on the Image Menu, then click Filters Unlimited. For this feature, you must first install the Filters 



Unlimited - PlugIn and download some filters from www.icnet.de.



Swap Colors

Click on the Image menu, then point the mouse at Swap Colors.    A submenu allows you to select one of
the color combinations to change the image.
 
This command operates at the pixel level, changing the color of all, or most, depending on which 
combination you select.

Example: if you choose RGB -> RBG, the pixels that are green will be made blue, and the blue pixels will 
be made green. (In this combination the red pixels stay the same.)

The possible swaps are:

RGB -> RBG
RGB -> BGR
RGB -> BRG
RGB -> GRB
RGB -> GBR



Palette

For images with 256 or fewer colors.

If you have a true color image, you can decrease the color depth in the Image menu.

Edit Palette
A dialog shows the colors at use in the image. Click any color for information about it. Double click to edit 
the color. Your changes will appear in the image. When you are satisfied, click OK to close the dialog.

This action can be reversed by the Edit menu's Undo command.

Export Palette
A dialog asks you for destination file/directory. The palette will be saved as PAL-File in PaintShopPro 
palette format.



Effects setup

Click on the Image Menu, point the mouse at Effects, then click Setup.    A dialog allows optional settings 
for many of the special effects.

To restore the default settings, click the Default Settings button at the bottom of the dialog.

When you are finished, click OK  to close. To exit without any changes, click Cancel.

The settings are:

Sharpen
Enter a value (1-99) to control how deep the sharpen effect is; higher numbers sharpen the image more; 
the default is 30.

Oil Paint
Enter an odd number (3, 5, 7 or 9) to control how coarse the oil paint effect is; higher numbers produce a 
more streaked effect; the default is 3; higher settings take longer to finish.

Explosion
Enter two values to control the mask value for explosion; this sets how coarse the explosion effect will be;
higher numbers produce a more coarse effect; the default is 3 x 3; higher settings take longer to finish.

Fine Rotation
Enter a value to control how far the image is rotated; positive numbers (e.g. 30) rotate the image to the 
right, negative (e.g. -30) rotate the image to the left; higher numbers rotate the image farther; the default 
is 45. If you click the Clear background check-box below, the area where the image was is blanked out, 
then the rotated image is placed over it; otherwise, the rotated image is placed on top of the existing 
image; the default is unchecked (no clear.)

Blur
Enter a value (1-99) to control how coarse the blur effect is; higher numbers produce a wider blur; the 
default is 30.

Median Filter
Enter an odd number (3, 5, 7 or 9) to control how coarse the median filter effect is; higher numbers cause 
the pixels to become more alike in brightness (most areas will appear "softer"); the default is 3; higher 
settings take longer to finish.

Pixelize
Enter two values to control the mask value for pixelize; this amount sets how coarse the pixel effect will 
be; higher numbers produce a more coarse effect; the default is 5 x 5; higher settings take longer to 
finish.

3D Button
Enter two values to control the width and height of the border for 3D buttons. The settings are in pixels; 15
is the default.



Filter Factory

Note: Filter Factory is used as PlugIn, download and install:

http://www.irfanview.com/plugins.html

Important note: IrfanView can'r read original Photoshop 8BF files, you must use 8BFs created with Filter 
Factory. You can find several such 8BFs under: 

http://www.netins.net/showcase/wolf359/adobepc.htm

Click on the Image Menu, point the mouse at Effects and click Filter Factory. A dialog opens    from which to 
control the filter.

Parameters sliders control the filter: these will cause the filter to act more, or less, on the image. Usually, 
moving the slider to the right increases the action, to the left decreases. Default slider values resets the 
sliders to whatever values were set by the author of the filter. 

Filter Groups help you keep track of them. The display shows the names of all groups available for use. 
You can add groups to the list, or remove them.

Filters displays the names of the filters in the selected group. You can add filters to the list. Click one of 
the names to see that filter. The preview image shows what the image will look like if you apply the filter. 
To use the filter, click Apply to image.    This can be reversed using the Undo button or by the Edit menu's
Undo command.

Add filter makes more filters available. A dialog box    allows you to find the directory in which your filters 
are stored. Click the Use dir button. All of the filter groups in that directory will be added to the list. Click 
Cancel    to exit without changes. Remove filter    removes the selected filter from the list. To remove 
filters in larger numbers, use Remove group, or Remove all groups. Removing a filter does not remove 
it from your hard drive, only from this list.

Filter info displays the filename, filter name, author name, and copyright information for a selected filter. 
When you are done reading the info, click OK.

Thanks to...  shows a message of thanks to Michael Johannhanwahr for Library provided for use with 
IrfanView.

When you have finished using the filters, click Exit.



Options Menu

          The following options are available on the Options Menu:

Properties

Start Multimedia Player

Stop Animation
Extract all frames

Send image by EMail

JPG Transformation

Capture

Sort directory files
Set as Wallpaper

Minimize
Always on Top



Properties

Click on the Options Menu, then Properties (or use the Properties    tool on the toolbar.) A dialog allows 
you to change many of the basic functions of IrfanView.

Click one of the tabs to see the properties in that section. They are: 

JPEG/PCD/GIF,    Extensions, Copy/Move/Delete, Viewing, Language, Video/Sound,Other Options 1, 
Other Options 2.



Stop Animation

Click on the Options Menu, then click Stop Animation to perform this action.
 
This is used to "freeze" animated GIFs or animated cursors, ANIs. The motion stops, and the GIF/ANI is 
made a single image. It can be saved as a non-animated image. 

If you want to save all the frames, use Extract all frames.



Extract all frames

Click on the Options Menu, then Extract All Frames. A dialog allows you to select the directory in which 
the frames will be stored. Find the directory you want, then click Use Dir to have the images stored there. 
Click Cancel to abort the change. This option is available for animated GIFs and animated cursors (ANI) 
images.

 To extract AVI video frames you need the external IV_Player.exe plugin installed & enabled with 
Properties->Video.

The frames from the image are placed into the directory with names like this:
 

imagename_frame_000.bmp
 
where imagename is the name of the original image, and 000 is the number of the frame. The frames are 
stored as bitmap (BMP) files.
 
Required. To continue, click OK. To exit without extracting the frames, click Cancel.
 



Capture

Click on the Options Menu, then Capture. A dialog allows you to capture portions of your screen. 

Capture - Area:
Use the option buttons to capture from your Whole screen, a Foreground window, or a Foreground 
window - client area (window without caption, menu and status bar). 

Capture - Method:
You can capture with a self-defined hotkey or use the automatic capturing. For automatic capturing set a 
timer value. The value will be the number of seconds apart the viewer will take "snapshots" of the screen 
or window. One hotkey is valid for the duration of current IrfanView session.

Saving - Method:
You can display each captured image in the main window or you can save to disk.
If you use save to disk, you can set:

·    Destination directory for images. Type in a directory path, or use the Browse button to find the 
directory you 

    want to use.
·    Save as box lets you choose which image format will be used to store the screens on your disk 

drive. Click the arrow and 
 select one of the formats to change from the default JPG. The Options button brings up another 
dialog box with 
 special options for certain file types.

Capture - Options:
If you want to see the mouse cursor in your screenshot image, check Include mouse cursor option.

Click Start to start capturing or Cancel    to exit.

Note: Click Options, then Capture again to stop any eventually started capture timer. 



Sort directory files

Click on the Options Menu and point at Sort Directory Files. A sub-menu appears with the choices by 
Name, by Date, by Size, and by Extension. These are available in either ascending or descending 
order. The final choice is No sort. Click your choice.

When you activate any of the options that use the space bar to move forward and backspace to move 
backward through the files, such as Full screen mode, they will be in the order set by your sort option.



Set as Wallpaper

Click on the Options Menu and point at Set as Wallpaper. A sub-menu appears with the choices 
Centered, Tiled,    and Previous wallpaper. Choose one to have the current image made into a 
background for your Windows desktop.
 
Centered  appears as just one image on the center of the screen. Tiled appears as multiple images, 
taking up the whole screen. (The desktop icons are on top of the wallpaper.) Previous wallpaper 
restores the image that was replaced by this operation.



Minimize

Click on the Options Menu, then Minimize to minimize the viewer to the Windows task bar (the 'Boss'-key
;-). 

Click the IrfanView button on the task bar to restore the viewer to use.

Another way to minimize is to click the minimize box in the upper right corner of the viewer window. It 
looks much like the underline ( _ ) character.



Always on Top

Click on the Options Menu, then Always on Top.

IrfanView will always be visible on your screen, even when you open other programs. This can be 
removed by clicking Always on Top again.

Note: this option will be saved and restored after next IrfanView start.



View Menu

          The following options are available on the View Menu:

Toolbar
Status bar

Full screen

Fit window to image
Fit image to window
Fit only big images to window
Fit window/image to desktop
Fit only big images to desktop
Do not fit anything

Next File in Directory
Previous File in Directory
First File in Directory
Last File in Directory
Random File in Directory
Refresh
Start/Stop automatic viewing

Zoom In
Zoom Out
Lock Zoom
Original size

Show HEX view

Multipage images



Toolbar

The toolbar allows quick access to some of the most useful features of IrfanView. 

Turn the toolbar on by using the View Menu, and selecting the Toolbar option. Turn the bar off by again 
clicking on View and Toolbar. There is an image of the Toolbar here.

The toolbar contains:

Open, Slideshow, Save As, Delete

Cut selection, Copy, Paste, Undo

Image Information

Zoom In, Zoom Out,
Previous File in Directory, 
Next File in Directory

Previous page
Next page

Directory Count Display

Properties,    About IrfanView



Full screen

Click on the View Menu, then Full screen. The image will be displayed centered on a black background, 
which fills the entire screen. Move through the images in the current directory using the spacebar for the 
next image, and backspace for previous.

To cancel Fullscreen mode,    press the Enter key, or the Esc key.
 
Resizing for Fullscreen mode can be done with resampling, for better results in most cases. Click the 
Options menu, then Properties, then the Viewing tab. Click the check-box next to Use 'Resample' 
function for 'Fit To Desktop' and Fullscreen mode. To turn it off, click again.
 
Other options for Fullscreen mode can be set from the Properties Viewing tab. The first is a set of option
buttons: Show images/movies with the normal size, Fit to screen: large images/movies only, and Fit
to screen: all images/movies. Click the option of your choice.

You can also set the background color for the fullscreen window and text.
 
The next option is Hide mouse cursor. If you don't want the cursor onscreen in Fullscreen mode, click 
this. To return the mouse, click again.
 
The final option is Show image filename. Click this to display the filename of the current image during 
Fullscreen mode. Click again to turn off. Click the box below, Show transparent, to have the filename 
appear as a light color against the black background. Uncheck the box for the filename to appear as black
text inside a white box.
 



Viewing options

Note: only one of these options is active.

Fit window to image
The window will be resized to fit the image. This is the recommended viewing option.

Fit image to window
The image will be resized to fit the window.

Fit only big images to window
Click this to have the viewer reduce oversized images until they can be seen fully in the window. Images 
smaller than the window will not be changed.

Fit window/image to desktop
The window/image will be resized to fit the desktop size.

Fit only big images to desktop
Click this to have the viewer reduce oversized images until they can be seen fully on the desktop. Images 
smaller than the desktop will not be changed.

Do not fit anything
No change in window size/position if the user loads a new image.



Next File in Directory

Click on the View Menu, then click Next File in Directory (or use the Next File tool on the toolbar.) The 
viewer displays the next supported file. 

If the image does not have a vertical scrollbar at its right edge, you can also use the Space or Page 
Down key to move to the next file in the directory.

See also:
          Previous File in Directory
          First File in Directory
          Last File in Directory
          Random File in Directory



Previous File in Directory

Click on the View Menu, then click Previous File in Directory (or use the Previous File tool on the 
toolbar.) The viewer displays the previous supported file, in reverse sequence.

If the image does not have a vertical scrollbar at its right edge, you can use the Backspace or Page Up 
key to move to the previous file in the directory.

See also:
          Next File in Directory
          First File in Directory
          Last File in Directory
          Random File in Directory



First File in Directory

Click on the View Menu, then First File in Directory. The viewer displays the first supported file in the 
current directory.

See also:
          Next File in Directory
          Previous File in Directory
          Last File in Directory
          Random File in Directory



Last File in Directory

Click on the View Menu, then Last File in Directory. The viewer displays the final supported file in the 
current directory.

See also:
          Next File in Directory
          Previous File in Directory
          First File in Directory
          Random File in Directory



Random File in Directory

Click on the View Menu, then Random File in Directory. The viewer displays a random supported file 
from the current directory.

See also:
          Next File in Directory
          Previous File in Directory
          First File in Directory
          Last File in Directory



Refresh

Click on the View Menu, then click Refresh. The image onscreen will be updated. 

The directory will be updated.

If you have an editing outline around an area of the image for, Refresh will remove it.



Zoom In

Click on the View Menu, then Zoom In (or use the Zoom In tool on the toolbar.) Increases size of the 
image. Click again for more increase. 

The amount of each increase can be set using Zoom Factor on the Options menu, Properties dialog, 
Viewing tab. The default is 10% increase per use.



Zoom Out

Click on the View Menu, then Zoom Out (or use the Zoom Out tool on the toolbar.) Decreases size of the 
image. Click again for more decrease. 

The amount of each decrease can be set using Zoom Factor on the Options menu, Properties dialog, 
Viewing tab. The default is 10% decrease per use.



Original size

Click on the View Menu, then Original Size.    Removes Zoom In or Zoom Out, returns image to its normal
size.



Multipage images

Note: This menu is activated only if you have an image with many pages! (some LDF/DCX/TIFF files)

Click on the View Menu, point at Multipage images.    A sub-menu opens, with several options. to click. 
The options are:

· Create Multipage LDF
IrfanView can create LDFs with max. 6 images (pages) per LDF file. You can add/remove images to fiile 
list and set LDF save options for each (image) page. Set the destination directory/file and press the button
Create LDF image or Exit to exit.
Note: LDF format is used as PlugIn, download and install:

http://www.irfanview.com/plugins.html

· Create Multipage TIF
Check this option to create multipage TIF images. You can save each page with a different TIF 
compression. If you want to set same compression for all pages, set the compression before you add any 
image.

· Next Page
Click Next Page (or use the Next Page tool on the toolbar.) The viewer displays the next page in 
sequence.
 
· Previous Page
Click Previous Page (or use the Previous Page tool on the toolbar.) The viewer displays the previous 
page in reverse sequence.
 
· First Page
Click First Page. The viewer displays the beginning page of the image.
 
· Last Page
Click Last Page. The viewer displays the final page of the image.
 
· Open Page Number ...
Click this menu and a dialog will be displayed. You can enter a page number to open.
 
· Print all pages
Click Print all pages. The Print dialog may be used to send all pages of the image to your printer.
 
· Extract all pages
Click Extract all pages. A dialog allows you to select the directory in which the pages will be stored. Find 
the directory you want, then click Use Dir to store the pages there. Click Cancel to abort.
 
The pages from the image are placed into the directory with names like this:
 
          name_irfanview_extract_000.bmp
 
where name is the name of the file and 000 is the number of the page. The pages are stored as bitmap 
(BMP) files.



· Start animation
Click this menu and choose the time intervall between the pages. The animation will be started.
 
· Stop animation
Click this menu to stop the animation.
 



Help Menu

          The following options are available on the Help Menu:

Help
Installed Plugins

Thanks

Registration

Info
About IrfanView



Thanks

Click the Help menu and select Thanks.
 
Displays a message of thanks from me,    Irfan Skiljan, to all the users of IrfanView.
 
When done viewing the information, click OK.



Registration

Click the Help menu and select Registration. A dialog allows you to enter your name and a registration 
code.
 
Although IrfanView is free for non-commercial use, it’s best to register your copy. The small fee helps the 
author continue developing one of the best viewer on the WWW.
 
When done registering, click OK.



Info

Click the Help menu and select Info. A dialog will explain who is allowed to use IrfanView for free, and 
where to send your registration fee.

 Also explains where to send bug reports, and other messages to the author. Tells you where to find the 
IrfanView website.

When done viewing the information, click OK.



About IrfanView

Click the Help menu and select About    (or use the About    tool on the toolbar.)
 
Gives the current version number of IrfanView, e-mail address for the author, and a photograph of his 
beautiful home town (worth a look, just for that.)
 
When done viewing the information, click on the bar that says "Click."



Help

Click on the Help menu, then Help. This Help file (the one you are reading now) will appear.

The first version of this WinHelp file was written by Steve Clark, changes after IrfanView ver. 3.02 by 
Irfan.

This Help file was created with HelpWriter ver. 4.2.0.

--------------------------------------
Many many thanks Steve! 
                                                                                                                    Irfan

--------------------------------------



Command Line Options

Command line options allow you to set some functions of IrfanView before the viewer is launched. 
 
These command line options are supported in IrfanView:

          /one - force 'Only one instance'
          /fs - force Full Screen
          /bf - force 'Fit window/image to desktop'
          /title=text - set window title to 'text'
          /pos=(x,y) - move the window to x,y
          /convert=filename - convert input file to 'filename'
          /slideshow=txtfile - play slideshow with the files from 'txtfile'
         /thumbs - force thumbnails
         /killmesoftly - close all IrfanView instances
          /closeslideshow - stop Slideshow and close IrfanView after the last image
          /page=Nr - open page number Nr from a multipage input image
          /crop=(x,y,w,h) - crop input image: x-start, y-start, width, height
          /print - print input image to default printer and close IrfanView
          /resize=(w,h) - resize input image to w (width) and h (height)
          /resample=(w,h) - resample input image to w (width) and h (height)
          /capture - capture the whole screen and show image in IrfanView

 
Note:    Only lower case options are supported (don't type any UPPERCASE    letters.)

Examples:

          i_view32.exe test.bmp /BF = incorrect

          i_view32.exe test.bmp /bf /title=My PIC = correct

Example for conversion:

          i_view32.exe c:\test.bmp /convert=c:\giftest.GIF

Convert file: 'c:\test.bmp' to 'c:\giftest.GIF' without GUI.

Example for slideshow:

          i_view32.exe /slideshow=c:\mypics.txt
 
The file 'c:\mypics.txt' contains, in each line, a name of the image, including the full path.

Example for thumbnails:



          i_view32.exe c:\test\image1.jpg /thumbs

Open 'image1.jpg' and display thumbnails from directory 'c:\test'.

Example for close: 

          i_view32.exe /killmesoftly

Close IrfanView and terminate all instances.

Example for /closeslideshow: 

          i_view32.exe /slideshow=c:\mypics.txt /closeslideshow

The file 'c:\mypics.txt' contains, in each line, a name of the image, including the full path. Close IrfanView 
after the last image from the TXT file.

Example for /page: 

          i_view32.exe c:\test.tif /page=3

Open page number 3 from the multipage image 'c:\test.tif'.

Example for /crop: 

          i_view32.exe c:\test.jpg /crop=(10,10,300,300)

Open 'c:\test.jpg' and crop: x-start=10, y-start=10, width=300, height=300 (in pixels).

Example for /print: 

          i_view32.exe c:\test.jpg /print

Open 'c:\test.jpg', print the image to default printer and close IrfanView.

Example for /resize: 

          i_view32.exe c:\test.jpg /resize=(300,300)

Open 'c:\test.jpg' and resize: width=300, height=300.

          i_view32.exe c:\test.jpg /resize=(300,0)



Open 'c:\test.jpg' and resize: width=300, height=proportional.

Example for /resample: 

          i_view32.exe c:\test.jpg /resample=(300,300)

Open 'c:\test.jpg' and resample: width=300, height=300 (using the active resample filter from the 
I_VIEW32.INI).

          i_view32.exe c:\test.jpg /resample=(0,300)

Open 'c:\test.jpg' and resample: width=proportional, height=300 (using the active resample filter from the 
I_VIEW32.INI).

Example for /capture: 

          i_view32.exe /capture



Installation

Setting up IrfanView for use.

For the experienced computer user: 

Download IrfanView, and unzip the files into a directory of your choice. Create a shortcut to the program 
in the Windows start menu, or on your desktop.

 
For the less-experienced computer user:

Download a self-install copy of IrfanView and start the instalation file.

Some informations: 
Unzipped, the file contains several files. "i_about.txt" describes the viewer, and gives information about 
the author. "i_changes.txt" is a history of versions of the program. "i_options.txt" outlines some 
advanced features of the program. "i_view32.exe" is the program that    makes IrfanView work. The two 
files "i_view32.hlp" and "i_view32.cnt" are the Help files for the program.

Shortcuts are the labels you click in the Start Menu, or the icons on your Desktop, that start programs for 
you. You need to create a shortcut to IrfanView. To make one on the Start Menu, click the Start button. 
Move the cursor up to point at Settings. On the sub-menu that appears, click Taskbar. A dialog box opens,
with two tabs. Click the tab that says: Start Menu Programs. In the top half of the box, click the Add 
button. A box called Create Shortcut comes up to put in the name of the program. Click the Browse 
button, and another box opens, to locate your copy of IrfanView. Find it, click it, then click the Open 
button. The box closes, and IrfanView is now selected. Click the Next button. A box comes up called 
Select Program Folder. Browse through to find the folder where you want the shortcut to appear on your 
Start Menu. Click the folder name, then click the Next button below. Finally, a box comes up called Select 
a Title for the Program. Click the Finish button at the bottom of the dialog. Next time you open your Start 
Menu, a clickable label for IrfanView will be in the folder you selected.
 
The easiest way to create a desktop shortcut is to use the viewer, itself. Open IrfanView. Click the 
Options menu, then click Properties. A dialog box opens; click the tab called Others 1. Almost at the 
bottom is a button labeled Create desktop link for IrfanView. Click this, and an icon for the viewer will 
appear on your desktop. Click the OK button to close. Next time you want to use the viewer,    just double 
click the icon.



Save, Options JPEG/GIF

JPEG
The upper half of this tab lets you set a quality level for JPG images. Move the slider control to the 
desired setting. Lower settings take less space, but deliver less quality. Higher settings are better, but 
take more file space. The default setting is 80, which is fine for most images.

Check the greyscale box to save the image as that. Click the Save progressive (like many images from 
internet) box to activate that option. Click either again to remove the choice.

GIF
The bottom half of the dialog has options for GIF images. Click the Save Interlaced (like many images 
from internet) box for that option. Click Save Transparent Color to set a transparency for the GIF. Type a
number in the box below to use that palette entry as the transparent color. For more on this, see Edit 
Palette. If you have a true color image, you must first decrease the color depth to 256 colors to see the 
palette.
 
After setting the options you choose, click OK to close the dialog. To exit without any changes, click 
Cancel. 

The new settings will stay in effect until you change them again.

See also:
          Save
          Save As
          Save, Options LDF
          Save, Options LWF
          Save, Options PNG/PNM
          Save, Options TIFF
          



Directory Count Display

On the toolbar, shows how many images are in the current directory, and which number is selected. "1/5" 
means the selection is number one out of five images in the directory.
 
To set a custom directory index, type a number into the box. The viewer will open that image.
 
For Multipage images, this gives the page location and number of pages. "1/5" means page one of five.



Properties, JPEG/PCD/GIF

Click on the Options Menu, then Properties. If the JPEG/PCD/GIF section is not showing, click its tab at 
the top of the box.

JPEG 
This part lets you select whether to load JPEG images as grayscale, which is faster. Click the check-box
if you want to use this option. Click it again to un-set the option.

 
PhotoCD
This part allows you to choose the size at which PhotoCD images are loaded. Click one of the option 
buttons to make your selection.

 
Animated GIF
Option buttons allow choice of several setups for animated GIFs. The default is to show animation. You 
can also choose to show only the first image in the GIF, or to extract all the images into a directory on 
your hard drive. If you choose the last option, be sure to type a directory in which to place the images.

Below the option buttons is a check-box to click if you want to show transparency in non-animated 
GIFs, as well.

When you are done, click OK. To exit without making any changes, click Cancel.



Properties, Extensions

Click on the Options Menu, then Properties. If the Extensions section is not showing, click its tab at the 
top of the box.

Here you choose which file types will be automatically associated with IrfanView. Those files will show 
the viewer's icon next to them in directories; double clicking the file name will launch the viewer, with the 
file already loaded. Click any of the check-boxes next to files you want to associate. If you want them all, 
click Select all.  Clear all  removes all associations.

At the bottom of the selections area is a box for entering other file extensions not listed. Click the box, 
then type in the extensions, each separated by a single space.

If you activate Load only associated types during moving through directory you will see only 
associated extensions if you move through a directory with space/backspace.

Below the selections area is a box you can click to Use Thumbnails for loading BMP images. It is 
checked by default. Click it to remove the option.

The Advanced button has some choices for Windows shell operations. Click to access these options: 
Add IrfanView To Send-to Menu, Add 'Browse with IrfanView' for Drives and Folders to Shell-Menu
and Add Open-browse to Shell Menu (This option can cause some problems with the MS Office 
toolbar!).

The Set Icon button allows you to choose a different icon for IrfanView. Click the button to see several 
choices; click an icon to choose it. Click OK to finish your choice, or Cancel    to exit without making any 
changes.

When you are done, click OK. To exit without making any changes, click Cancel.



Properties, Copy/Move/Delete

Click on the Options Menu, then Properties. If the Copy/Move/Delete section is not showing, click its tab 
at the top of the box.
 
The first section allows setting a default directory for Copy operations. Type in a directory, or click the 
browse button to select one. If you click the check-box below, IrfanView will ask your permission before 
making any copies.
 
The second section sets a default directory for Move operations. Click the check-box to have IrfanView 
ask permission before moving files.
 
The third section has several check-boxes that refer to delete operations. You may choose to have 
IrfanView ask permission before deleting files, send deleted files to the Windows Recycle Bin, or 
jump to the next file after deleting one. Click any or all of the boxes to select these options.
 
When you are done, click OK . To exit without any changes, click Cancel.



Properties, Viewing

Click on the Options Menu, then Properties. If the Viewing section is not showing, click its tab at the top 
of the box.

The top half of this dialog has several options. The first is View all files in directory. Click this to have 
the viewer display all file extensions supported by IrfanView in each directory. If this is un-checked, you 
can't open next/previuos file with space/backspace or with the toolbar arrows.

The next option sets the Zoom factor for Zoom In and Zoom Out. The default is 10% increase or 
decrease each time you zoom the image. Type a number in the box to change this amount.
 
The next option is Use 'Resample' function Fit-To-Desktop and for Fullscreen mode. Click this to 
have the viewer display the best possible version of an image when you put it in Full screen mode or if 
you use fit options in the viewing menu.

The next option is Dither 24 BPP images on 16 BPP displays. Click this if you want better displaying of 
the true color images if you have 65536 colors under your Windows.

The next option is Enable gamma correction. Enable it if you want to change the intensity of each loded 
image. The default value is 1.00 (no changes), the range is between 0.01 and 6.99.

The next option is the background color option for the main window. You can choose any color as 
background. Default is black.

The bottom half of this tab contains options for the Full screen mode:

The first is a set of option buttons: Show images/movies with the normal size, Fit to screen larger 
images/movies only, and Fit to screen all images/movies. Click your choice. The next option is Hide 
mouse cursor. Click this to prevent the mouse cursor from showing onscreen while the images are 
displayed. The next option is Show image filename. Click this to have the name of each image displayed
onscreen with the image. Below this option is Show transparent. If this is un-checked, the filename will 
appear in a small box.. Check this and the filename will be shown without the box.

You can also set the background color for fullscreen and fullscreen text.

When you are done, click OK. To exit without making any changes, click Cancel.



Properties, Others 1

Click on the Options Menu, then Properties. If the Others 1 section is not showing, click its tab at the top 
of the box.
 
Check-boxes allow access to options; click any that you want to select. They are:
 
· Use Undo option:    Unchecking disables this function of the Edit Menu.

· Ask to overwrite for Save and Save As: checking makes the viewer ask permission before it destroys an 
old file in favor of a new one.

· Display Save dialog for File -> Save:    when checked, clicking on Save will bring up the standard 
dialog, through which you can choose a directory in which to save the image. Uncheck the option and 
Save will resave an image in place of the original. Note that this is only for Save; clicking on Save As still 
brings up the dialog box.

· Only 1 Instance of IrfanView: unchecking will allow the viewer to open more than once at the same 
time. Checking the box will prevent more than one instance of the viewer at any time.

· Ask to Rename Incorrect Extension:    while loading a file which has had the name given an incorrect 
extension, IrfanView will ask permission before changing it. If you uncheck this box, the viewer will load 
the file without making any changes.

· Jump always to next image if Page Up/Down pressed:    don't scroll large images, jump always to 
previous/next image if you press Page Up/Down keys.

· Don't notify if end/begin of directory is reached:  when you reach the last of the images in a 
directory, IrfanView asks if you want to jump to the first again; checking this option will suppress the 
question, and just go right to the first image. In reverse direction, it will go to the last image.
 
There are also two buttons, for further options:
 
· Clear MRUDs list: clicking this removes all the names from the Most Recently Used Directories list; this 
option may be used at any time.

· Create Desktop Link: places an icon on your Windows desktop that can be double clicked to start the 
viewer.
 
When you are done making selections, click OK. To exit without any changes, click Cancel.

See also:
          Properties, Others 2



Save, Options LWF

LWF
Click one of the option buttons to set a compression level for LWF images. If you select Compression 
Rate, Quality or Compress to bytes, type in a value for the option.
 
Set Progressive (faster for small images) or Baseline (better for large images) mode.

After setting your options, click OK to close the dialog. To exit without any changes, click Cancel. 
 
The new settings will stay in effect until you change them again.

See also:
          Save
          Save As
          Save, Options JPEG/GIF
          Save, Options LDF
          Save, Options PNG/PNM
          Save, Options TIFF



Save, Options TIFF

TIFF
Click one of the option buttons to set a compression type for TIFFs. The left side is for color images, the 
right may be used for black & white.
 
After setting your options, click OK to close the dialog. To exit without any changes, click Cancel. 
 
The new settings will stay in effect until you change them again.

See also:
          Save
          Save As
          Save, Options JPEG/GIF
          Save Options LDF
          Save, Options LWF
          Save, Options PNG/PNM



Open with external editor

Click on the File menu, then Open with external editor.    Your chosen "other" viewer/editor will be 
launched, with the image loaded into it (e.g. Adobe Photoshop, Paint Shop Pro etc.).

To use this option, you must first select an external editor.

See also:
          Open
          Reopen



Properties, Others 2

Click on the Options Menu, then Properties. If the Others 2 section is not showing, click its tab at the top 
of the box.

A box allows you to "Set external viewer/editor (for Menu 'File' and Thumbnail window):"    Type in the
location of another graphics viewer or editor, with the full path to where it is on your hard drive. You can 
also click the Browse button to locate the program.    Now when you click the Open with external editor 
option on the File Menu or Thumbnail window, your selected editor will be launched, with the current 
image shown in it.

The next option is Center window if loading new image. Click this, and each time you load a new image
in the viewer, it will be centered on your desktop.

The next option is Remember the last window position. Click this, and each time you open the viewer, 
it will be positioned on your screen where it was when you last closed it. This option works only if you use 
the following viewing options: 'Fit image to window' or 'Do not fit anything'.

The next option is Load DJVU files with maximal DPIs. Click this to load DJVU/IW44 images with 
maximal saved size.

The next option is Don't change directory index after file renaming: when checked, the current 
directory index will be not changed if you rename a file, otherweise, the index    will be changed to the new
position in the name list. Add MRUDs to menu File; enable/disable MRUDs (most recently used 
directories) in the File menu.

Default printer for "/print" command line option: set the destination printer for this command line 
option in case of problems.

When you are done making your selection, click OK. To exit without any changes, click Cancel.

See also:
          Properties, Others 1



Start or Stop automatic viewing

Click on the View Menu, then Start/Stop automatic viewing. The window-slideshow will be started, with 
images from the current directory. Click again on this menu to stop the automatic viewing.



Hotkeys

Available keyboard shortcuts in IrfanView:

Key: Function:

+ Zoom In                        
 - Zoom Out
é Scroll image up
ê Scroll image down
è Scroll image right
ç Scroll image left
TAB Switch between main and thumbnail (if visible) window
A About-Box dialog
CTRL + A Acquire
B Batch Conversion dialog
C Capture dialog
CTRL + C Edit -> Copy
CTRL + SHIFT + C Set as wallpaper - centered
D Edit -> Delete
CTRL + E Effects setup
F Switch between 'Fit window/image to desktop' and 'Fit window to image'
CTRL + F Open first file in the directory
G Stop GIF or ANI animation
SHIFT + G Enhance colors
H Horizontal flip
CTRL + H Original size (no zoom)
I Image information
K Filter Factory dialog
L Rotate left
CTRL + L Open last file in the directory
M Minimize IrfanView window (Boss key ;-)
CTRL + M Open random image from the directory
CTRL + N Show next page in a multipage TIFF
O Open dialog
P Properties dialog
CTRL + P Show previous page in a multipage TIFF
SHIFT + P Print dialog
CTRL + SHIFT + P Set as wallpaper - previuos wallpaper
R Rotate right
CTRL + R Resample dialog
SHIFT + R Reopen file
S Save as - dialog
CTRL + S Save - dialog
T Thumbnails
CTRL + SHIFT + T Set as wallpaper - tiled
U Refresh (display and directory list)
V Vertical flip
CTRL + V Edit -> Paste
F1 Help



F2/F6 Rename
F3 Show image in HEX viewer
INSERT Edit -> Paste
W Slideshow dialog
CTRL + W Slideshow with current directory files
CTRL + X Edit -> Cut
CTRL+ Y Edit -> Crop
CTRL+ Z Edit -> Undo                                    
Space Load next file in directory
Backspace Load previous file in directory
CTRL+ Page Down Load next file in directory
CTRL+ Page Up Load previous file in directory
Page Up Load previous file in directory OR scroll image up
Page Down Load next file in directory OR scroll image down
Home Scroll to begin (horizontal scroll)
End Scroll to end (horizontal scroll)

Available mouse shortcuts in IrfanView:

Normal mode:

Left button drag Make a Selection
Right button drag Scroll image in direction of drag
Left button double-click Switch to fullscreen mode
Wheel up Load previous file in directory OR scroll image up
Wheel down Load next file in directory OR scroll image down

Fullscreen mode:

Left button click Load previous image in the directory
Right button click Load next image in the directory



Uninstall IrfanView

How to uninstall IrfanView:

1. Start IrfanView and go to Properties -> Extensions

2.    Press the Advanced-button and uncheck all options. Press OK.

3. Unselect all extensions and press OK (The most extensions will be free now, you must start another 
viewer and associate your extensions)

4. Close IrfanView (and delete IrfanView folder)



Open in HEX Viewer

Click on the File menu, then Open in HEX viewer. You can open any file in the HEX viewer.
You can see all bytes in HEX and ASCII mode of the opened file.

This option is used by advanced users.

To close without opening a file, click Cancel .  Another way to close is to click the X    in the upper right 
corner.



Show HEX view

Click on the View Menu, then Show HEX view. This option will show you the HEX view of the current 
image.
You can see all bytes in HEX and ASCII mode of the opened file.

This option is used by advanced users.



Count colors used

Click on the Image menu, then Count colors used. 

The number of unique colors in this image is displayed.



Batch Scanning

Note: Batch Scanning feature works only if your device (scanner, camera etc.) supports batch! (Paper 
feed etc.)

Click on the File menu, click Batch Scanning. 

First, you can set:

· output file name
· starting index for output files
· output directory for scanned images
· save file type

The program that runs your scanner, or any other TWAIN compatible device (digital camera, TV card 
etc.), will appear. Follow the steps given in your scanner's manual for scanning an image. 

Images will be saved in the output directory as image files. The file names are "ScanImage01.bmp", 
"ScanImage02.bmp" etc. (if default settings).

When finished, the last scanned image will be placed into IrfanView.

See also:
          Select TWAIN Source



Save, Options PNG / PBM/PGM/PPM

PNG
Set the compression level for PNG images.

PBM, PGM, PPM
Click one of the option buttons to set a encoding type for PBM/PGM/PPMs. Ascii will produce very large 
files.
 
After setting your options, click OK to close the dialog. To exit without any changes, click Cancel. 
 
The new settings will stay in effect until you change them again.

See also:
          Save
          Save As
          Save, Options JPEG/GIF
          Save, Options LDF
          Save, Options LWF
          Save, Options TIFF



Frequently Asked Questions

Here are some interesting questions about IrfanView , bug reports etc.

Q: I will create a CD-ROM with images and I will put IrfanView on the CD. How can I start IrfanView's 
Slideshow when I insert the CD in the drive?
A: First: put IrfanView in to the root CD directory. Second, create a TXT file with files for the slideshow; 
you can use RELATIVE path names too. Third: put in your "autorun.inf" the IrfanView call "i_view32.exe 
/slideshow=txt_file_name".

Q: Bug report: since yesterday, IrfanView shows all images distorted! Why?
A: The view menu option "Fit window/image to desktop" is activated (or a similar view option), please 
uncheck.

Q: How can I make IrfanView as my default viewer?
A: Start IrfanView, go to 'properties->extensions' and associate your types.

Q: Bug report: the thumbnail window crashes if I have many files in a folder!
A: Again, this is a Windows 95/98 bug, the max. number of files in the folder is system dependent. 
WinNT/Win2K works fine.

Q: Bug report: if I try to play some AVIs and MPGs with IrfanView, I always get the error message 
"MMSYSTEM XXX, no device ..."!
A: IrfanView uses the Windows MCI driver for playing of most multimedia formats. This driver is either not
installed or can't play this file. Please install MS ActiveMovie ('amovie.exe', ca. 1 MB) or MS Media Player
or search the Internet for right codec (read next Question!) and install it.

Q: Bug report: if I try to play some AVIs, I get the error message "Video not available, cannot find vids 
decompressor"!
A: The correct video codec is not installed, please check this site for the right codec:    

http://www.webartz.com/fourcc/indexcod.htm

Q: Bug report: in the thumbnail window, when I click on a thumbnail, nothing happens, the image will be 
not displayed in the main window!
A: You have an old version of the "comctl32.dll", please update this Windows component from the MS 
homepage:

http://www.microsoft.com/msdownload/ieplatform/ie/comctrlx86.asp



Q: Problem: When double-click an file which is associated with IrfanView, I get an error message "Cannot
find the file [path] or one of its components". What is the problem?
A: Start IrfanView, go to 'properties->extensions' and associate your types again.

Q: Bug report: since yesterday, IrfanView shows all my images black/white! Why?
A: The load option for JPGs "Load as grayscale" in 'properties->JPEG' is activated, please uncheck ...

Q: Bug report: there is a memory problem when I view many WMF/EMFs with IrfanView in the fullscreen 
mode!
A: This is a Windows95/98 problem, IrfanView uses the Windows metafile driver. WinNT works fine ...



PlugIns

Please use always the current IrfanView    and PlugIn version ...

How to install IrfanView PlugIns?
    
1. Visit IrfanView 's homepage: http://www.irfanview.com (or a mirror site)
2. Go to 'Download -> PlugIns'
3. Download PlugIns
4. Click on the PlugIn file
5. PlugIns will be installed into IrfanView 'PlugIns' directory
        

Direct download:

You can download all PlugIns from this site:
        http://www.irfanview.com/plugins.html

Available PlugIns:

1. MP3 - PlugIn: allows IrfanView to play MP3/MP2/MP1 files.

2. VIDEO - PlugIn: allows IrfanView to play video/sound files.
              (AVI, MPG/MPEG, WAV, MOV, MID/RMI, AIF, AU/SND).

3. Multimedia Player - PlugIn: allows IrfanView to play video/sound/audio-cd files.
            Current formats:      AVI, MPG, WAV, MIDI, CDA, WMA, ASF, AIF, SND etc.

4. LWF - PlugIn: allows IrfanView to read/write LuraWave LWF files.

5. LDF - PlugIn: allows IrfanView to read/write LuraDocument LDF files.

6. FPX - PlugIn: allows IrfanView to read FlashPix files.

7. EMAIL - PlugIn: allows IrfanView to send images as EMails.

8. JPG Transformation - PlugIn: allows IrfanView to support lossless JPG transformations.

9. PCD - PlugIn: allows IrfanView to read Kodak PhotoCD files.

10. QuickTime - PlugIn: allows IrfanView to play Apple Quicktime movies.

11. KDC - PlugIn: allows IrfanView to read Kodak Digital Camera files.

12. Filter Factory - PlugIn: allows IrfanView to use Filter Factory 8BF files (Photoshop PlugIns).



13. Formats - PlugIn: allows IrfanView to read some rare image formats. 
            Current formats:      G3, RAS, BioRAD, Dicom/ACR, Mosaic, XBM, XPM, IMG, SGI, RLE, WBMP.

14. FLASH - PlugIn: allows IrfanView to read Macromedia Flash/Shockwave files.

15. DJVU - PlugIn: allows IrfanView to read AT&T DJVU files.

16. REAL AUDIO - PlugIn: allows IrfanView to play Real Audio RA files.

17. Filters Unlimited - PlugIn: allows IrfanView to use Filters Unlimited files (Photoshop PlugIns).
            Check www.icnet.de for filters.

18. NCC - PlugIn: allows IrfanView to display NCC information from JPG, GIF and PNG files.
            Check www.netcybercards.com for full info.

19. SFF - PlugIn: allows IrfanView to read Structured Fax Files.

20. LOGOMANAGER - PlugIn: allows IrfanView to read Nokia Logo Files: 
NLM/NOL/NGG/NSL/OTB/GSM.

21. MED - PlugIn: allows IrfanView to play MED/OctaMED audio files.

22. EXIF - PlugIn: allows IrfanView to show EXIF information from JPG files.

23. IPTC - PlugIn: allows IrfanView to show IPTC information from JPG files.



Create new image

Click on the Image Menu, then Create new image. A dialog allows you to create a new (empty) image. 

You can set the image width/height, number of colors (BPP) or grayscale and the background color 
(default is black).



Installed PlugIns

Click the Help menu and select Installed Plugins.
 
Displays a dialog with installed IrfanView Plugins.
 
When done viewing the information, click OK.



Lock Zoom

Click on the View Menu, then Lock Zoom . This option can be checked only if the viewing option is 'Fit 
window to image'.
If checked, the actual zoom factor is saved and used for all new loaded images.

This option is activated only for current session.

Click this option again to deactivate Lock Zoom. 



Save, Options LDF

LDF
Set the profiile option. There are 5 standard profiles for different image/color types. You can set the quality
of the result LDF image. 

If you want the thumbnail in the LDF image (for faster preview), check Save Thumbnail option.

If you want to create multipage LDF images, click on the View Menu, then click Multipage images -> 
Create Multipage LDF.
 
After setting your options, click OK to close the dialog. To exit without any changes, click Cancel. 
 
The new settings will stay in effect until you change them again.

See also:
          Save
          Save As
          Save, Options JPEG/GIF
          Save, Options LWF
          Save, Options PNG/PNM
          Save, Options TIFF



JPG Transformation

Note: JPG Transformation is used as PlugIn, download and install:

http://www.irfanview.com/plugins.html

Note: This feature is available only if you load a JPG file.

Click on the Options Menu, then JPG Transformation. A dialog allows you to rotate or flip a JPG file. 

Warning: your original JPG file will be changed!

Click Start to transform the loaded JPG or Cancel    to exit.



Status Bar

The status bar shows some informations about the displayed image at the bottom side of the main 
window. 

Turn the status bar on by using the View Menu, and selecting the Status Bar option. Turn the bar off by 
again clicking on View and Status Bar. 



Start Multimedia Player

Note: The Multimedia Player is used as PlugIn, download and install:

http://www.irfanview.com/plugins.html

Click on the Options, then Start Multimedia Player.

The Multimedia Player allows IrfanView to play video, sound and audio-CD files like:

AVI, ASF, MP3, MPG/MPEG, MOV, MID/RMI, WAV, WMA , CDA etc.

The Player can play these formats through the MCI interface or using the Microsoft Media Player 
(recommended). 

The Player can extract frames from AVI files and has a built-in audio CD player.

You can close the Player with ESC key.



Send image by EMail

Note: The EMail feature is used as PlugIn, download and install:

http://www.irfanview.com/plugins.html

Click on the Options, then Send image by EMail.

First, you must set the email options like SMTP server and your email address (check your email software
to see these settings). You can also use MAPI protocol for email sending.

There is a simple address book for your buddies.

Click on Send to send the image or Exit to leave the dialog without sending.



Properties, Video/Sound

Click on the Options Menu, then Properties. If the Video/Sound section is not showing, click its tab at the 
top of the box.

This dialog shows you options for video/sound playing. Videos/sounds can be played in the main window 
(default) or in the IV_Player PlugIn.

Apple QuickTime options:

IrfanView has QuickTime support! This allows IrfanView to read following formats: MOV, QTIF, Mac 
PICT, FLI/FLC. You can enable/disable this support for these formats.



Properties, Language

Click on the Options Menu, then Properties. If the Language section is not showing, click its tab at the top
of the box.

This dialog allows you to change (on-the-fly) IrfanView     language.

Choose the language in the language list and press OK to activate it.

Visit this site for available languages and SDK for translators:

http://www.irfanview.com/languages.html



Glossary

A
AIF
ANI
AU
AVI
B
BMP
C
CAM
capture
check-box
clipboard
CLP
CPT
CUR
D
DAT
DCM/ACR
DCX
dialog
DIB
Dicom/ACR
DJVU
DLL
drag
dragging
E
EMF
EPS
EXE
extension
F
fill color
filter
Filter Factory
FLI/FLC
FPX
G
G3
GIF
grayscale
greyscale
I
ICL
ICO
IFF
IFF/LBM
image



IMG
interlaced
J
JPEG
JPG
JPG/JPEG
K
KDC
L
landscape
LBM
LDF
LWF
M
Mac PICT
maximize
MED
MID
minimize
MOV
MP3
MPEG
MPG
MPG/MPEG
O
option button
outline
P
PBM
PCD
PCX
PGM
PhotoCD
pixel
PNG
portrait
PPM
progressive
PSD
PSP
Q
QTIF
R
RAS
RAS/SUN
RealAudio
RLE
RMI
S
SFF
SFW
SGI/RGB
slider control



SND
sub-menu
SUN
SWF
T
tabs
task bar
TGA
thumbnail
TIF
TIFF
TIFF/TIF
transparent color
W
WAV
WBMP
Windows Clipboard
WMF
X
XBM
XPM



AIF
Sound file, Audio Interchange Format from Amiga computers.



ANI
Animated Cursor format for Microsoft Windows.



AU
Encoded Audio format used by Sun and NeXT machines.



AVI
Audio Video Interleaved: Microsoft's video format for Windows.



BMP
Windows Bitmap: The image format Microsoft created for use in Windows.



CAM
Casio digital camera file.



capture
To store a part of the monitor screen in memory and turn it into an image, which can be saved and 
modified just like any other image. Capture utility programs (such as that in IrfanView) let you choose 
exactly which part of the screen to save.



check-box
A small square box, usually to the left of some text; clicking the box with the mouse makes a mark 
appear, showing it as a selected option. The text identifies what the option is for. Often check-boxes 
appear in groups, to allow multiple selections.



clipboard
An area used by Windows to store various file information for cut/copy/paste operations. For programs 
that support the clipboard (most do,) you can cut or copy from one application, and paste into another. An
example: an image edited pixel-by-pixel in Windows Paint can be copied to the clipboard, then pasted 
into IrfanView, from which it can be saved in a variety of formats. (Paint only saves as bmp.) Each time 
you cut or copy to the clipboard, it replaces whatever was there before.



CLP
Windows clipboard format; used to store various types of files for Windows cut/copy/paste operations.



CPT
CorelDraw Photopaint image, IrfanView can read only older versions, Photopaint 6, 5 etc.



CUR
Cursor Resource file format for Microsoft Windows; contains image data for cursors used by Windows 
applications. (Files may contain multiple images, plus a directory.)



DAT
Video CD format; don't confuse this with Windows dat files, which hold information about programs and 
such.



DCM/ACR
Dicom/ACR file format for medical images.
Note: DICOM/ACR format hasn't a specific header and IrfanView can't recognize all such images. If you 
want to read Dicom/ACR images with IrfanView the file extension MUST BE ".dcm" or ".acr".



DCX
Multipage PCX    files format.



dialog
In Windows, a box that appears when you click a menu item or button. The box will contain items from 
which you can select, to more accurately perform a function. For example, a Files dialog allows you to 
browse through the files on your hard drive, choose the one you want, and open it.



DIB
Device Independent Bitmap: another form of BMP, used widely with printers and display devices.



Dicom/ACR
Dicom/ACR file format for medical images.
Note: DICOM/ACR format hasn't a specific header and IrfanView can't recognize all such images. If you 
want to read Dicom/ACR images with IrfanView the file extension MUST BE ".dcm" or ".acr".



DJVU
DejaVu image format from AT&T,
with good compression



DLL
Dynamic Link Library; under Windows, a file that can contain portions of a program, to make the program 
more useful; it can also hold information to help the main program do its job better; many dll's hold icons 
that can be opened in IrfanView.



drag
Pulling the mouse, usually while holding down one of the buttons. This is used to highlight or outline an 
area, so that some special operation (such as cut or paste) can be performed on the area you select.



dragging
Pulling the mouse, usually while holding down one of the buttons. This is used to highlight or outline an 
area, so that some special operation (such as cut or paste) can be performed on the area you select.



EMF
Enhanced Metafile Format; Microsoft's device-independent vector format for Windows.



EPS
Encapsulated PostScript: mostly used for desktop publishing; uses the Postscript page description 
language; these can be used on both PCs and Macs.
Note: IrfanView can open only EPSs with a TIFF preview image.



EXE
Executable file under DOS and Windows; many exe's contain    icons that can be opened in IrfanView.



extension
The part of a filename that comes after the dot (.) character. In a filename such as "i_view32.exe" the 
"exe" is the extension, and tells us this is an executable file - one that performs a function. (In this case, it 
is the IrfanView program file.) Some common graphics file extensions include .jpg, .gif, and .tif.



fill color
A color used to fill a large area, as opposed to drawing individual lines; if you see a drawn circle and the 
inside area of the circle is yellow, yellow is the fill color.



filter
For images: a small computer program that performs some action on the image, changing it in specific 
ways; filters can be used to smooth or roughen an image, correct or remove the color, and perform many 
other editing functions; most often, filters are used to create special effects.



Filter Factory
A creation tool for image filters. These filters are Photoshop compatible. With filters, you can produce an 
almost endless series of special effects from very tiny changes in the image to complete makeovers. 
There are thousands of such filters available;    many can be found    for free on the internet.



FLI/FLC
Autodesk animation format



FPX
Flashpix format



G3
Group 3 Facsimile Apparatus format, used for document transmission.



GIF
Graphics Interchange Format: The format created by CompuServe for the faster exchange of graphics 
over modem lines; widely used in Web publishing.



grayscale
Despite the name, grayscale is actually a mode of color; it uses 256 shades of grey to render an image, 
producing a richly varied tonal quality; black and white uses just two colors, black with white spacing to 
render.



greyscale
Despite the name, greyscale is actually a mode of color; it uses 256 shades of grey to render an image, 
producing a richly varied tonal quality; black and white uses just two colors, black with white spacing to 
render.



ICL
Icon Library format, used by many icon editing programs; can contain one or many icons for use in other 
programs.



ICO
Windows    Icon: used by Windows to represent programs and other files.



IFF
Interchange File Format: the image format standard for Amiga computers.



IFF/LBM
Interchange File Format: the image format standard for Amiga computers.



image
The graphics you see on your screen; they can be photographs showing your home town, line drawings 
showing Mickey Mouse, even the undulating, weird backgrounds you see at many WWW websites. They 
can range in size from a single dot on your screen (so small it is difficult to see,) to huge objects that go 
off the screen in all directions, causing you to scroll the screen back and forth, up and down, to see them.



IMG
GEM Raster image, from Atari



interlaced
In terms of some image types, such as gif: an image which builds up on the screen, showing the full 
image, but of low quality, then gradually building until the full quality image is visible. This allows the user 
to see some of the image as it builds. This is much the same as Progressive.



JPEG
Joint Photographic Experts Group: 24-bit support and fine compression make this format another 
standard for publishing on the Web.



JPG
Joint Photographic Experts Group: 24-bit support and fine compression make this format another 
standard for publishing on the Web.



JPG/JPEG
Joint Photographic Experts Group: 24-bit support and fine compression make this format another 
standard for publishing on the Web.



KDC
Kodak digital camera format



landscape
In reference to printers, printing an image so that it is faced with one long edge of the paper nearest you, 
as most landscape paintings would be faced. The other standard facing is Portrait.



LBM
Interchange File Format: the image format standard for Amiga computers.



LDF
LuraDocument Format: wavelet compression image format from LuraTech GmbH, Germany. Format 
enhanced to improve on JPG and other scanned images, with better quality and more control options. 

Note: IrfanView can't save images larger than 4096x4096 as LDF and max. 6 pages per LDF image.



LWF
LuraWave Format: wavelet compression image format from LuraTech GmbH, Germany. Format 
enhanced to improve on JPG, with better quality and more control options. IrfanView is the first viewer 
with LWF support.

Note: IrfanView can't save images larger than 4096x4096 as LWF.



Mac PICT
Macintosh PICT format



maximize
To "blow up" a program window so that it fills the entire screen. This is useful if the information in the 
program does not fully display at a smaller screen size.



MED
MED/OctaMED sound format



MID
Musical Instrument Digital Interface (MIDI): a file created with a set of standard formats to instruct 
electronic musical instruments how to play; with a MIDI player (such as IrfanView,) you can play a basic 
version of the song through the computer's speakers.



minimize
To remove a program, such as IrfanView, from the screen and have it appear as a button on the task bar 
at bottom of the screen. Click the button to restore the program to the screen.



MOV
Quick Time Movie format; Apple Computer's format for movie and other time-based data file storage.
Note: IrfanView uses the MS Active Movie for MOV playing. Active Movie can't play all MOVs, especially 
many QuickTime-created MOVs.
Install Apple Quick Time and check Properties->Others 2 in IrfanView ;-)



MP3
MPEG audio layer 3 format, very popular :-)



MPEG
Moving Pictures Experts Group: a standard for full-motion video; provides 352x240 resolution, 30 frames 
per second, and CD-quality sound; also used to compress audio without video.



MPG
Moving Pictures Experts Group: a standard for full-motion video; provides 352x240 resolution, 30 frames 
per second, and CD-quality sound; also used to compress audio without video.



MPG/MPEG
Moving Pictures Experts Group: a standard for full-motion video; provides 352x240 resolution, 30 frames 
per second, and CD-quality sound; also used to compress audio without video.



option button
A small circle, usually to the left of some text; clicking the circle with the mouse makes a mark appear, 
showing it as a selected option. The text identifies what the option is for. Option buttons appear in groups,
to allow a single selection from many choices; clicking one automatically "unclicks" all the others. 
Sometimes these groups are known as radio buttons, for their similarity to selecting a station on a radio.



outline
Highlighting an area you want to work on.

Put the mouse cursor at one corner of the area you want to outline. Press the left button, and hold it. Drag
the mouse across and down (or up,)    to the opposite corner of the area you want outlined. A border 
appears as you drag the mouse. Release the button when you are done dragging.
 
This technique is used in such operations as cropping, and adding text to an image. If the buttons on your
mouse are reversed, use the right button as described above.



PBM
Portable Bitmap File format; mostly used to convert between various types of bitmap images.



PCD
Digital images from Kodak, presented as "slides" on a CD-ROM. IrfanView can open the Overview-PCD 
files too!



PCX
PC Paintbrush format from ZSoft Corporation. These images are used by many word-processing and 
desktop publishing programs.



PGM
Portable Greymap File format; mostly used to convert between various types of greymap images.



PhotoCD
Digital images from Kodak, presented as "slides" on a CD-ROM. IrfanView can open the Overview-PCD 
files too!



pixel
Picture element: One dot in an image. It is the smallest (practical) element used to make up a picture.



PNG
Portable Network Graphics: A format that combines the best qualities of gifs and jpgs; used for Web 
publishing.



portrait
In reference to printers, printing an image so that it is faced with one short edge of the paper nearest you,
as most portrait paintings would be faced. The other standard facing is Landscape.



PPM
Portable Pixelmap format; mostly used to convert between various types of color images.



progressive
In terms of some image types, such as jpg: an image which builds up on the screen, showing the full 
image, but of low quality, then gradually building until the full quality image is visible. This allows the user 
to see some of the image as it builds. This is much the same as Interlaced.



PSD
PhotoShop Software Development file, used for development with Adobe Photoshop and related 
software.
Note: IrfanView (and other viewers too) can't correct display some PSD files, especially CMYK PSDs.



PSP
Paint Shop Pro file format, from Jasc Software; special graphics format that can describe a multi-layered 
image in complete detail.
Note: IrfanView will display only the first layer (if many) in a PSP image.



QTIF
Quick Time format



RAS
Sun Raster: The native bitmap file format for Sun Microsystems    workstations.



RAS/SUN
Sun Raster: The native bitmap file format for Sun Microsystems    workstations.



RealAudio
RealAudio (*.ra): audio/video format developed by RealNetworks, www.real.com. IrfanView plays RA-files
with the player plugin, please download and install.



RLE
Utah Run Length Encoded image format



RMI
MIDI file (MIDI sequence.)    See also: MID.



SFF
Structured Fax File.



SFW
Seattle Film Works format



SGI/RGB
Silicon Graphics image format



slider control
A control used in Windows to set a value for something. An example: in IrfanView, click on the Image 
menu, then select Brightness. A dialog opens with a slider control that allows you to set the value of 
brightness you want. In the Brightness control, the value starts at zero, and you can move the slider down
to -255 (less bright,) or up to +255 (more bright.) Click on one of the arrows to move the setting slowly. 
Click the area between the arrows to move the settings more rapidly. Put the mouse directly on the 
control bar (the box that starts at the zero setting,) press the left mouse button and hold it, and drag the 
bar to change the settings very rapidly. Most slider controls are similar.



SND
Sun-workstation sound file, similar to AU.



sub-menu
On a Windows menu, an extra menu that "pops up" when you point the mouse at one of the menu 
choices. This sub-menu gives further control over the choice. An example: on the Image menu, point the 
mouse at Effects; a sub-menu will appear to let you choose which effect to perform.



SUN
Sun Raster: The native bitmap file format for Sun Microsystems    workstations.



SWF
Macromedia's Shockwave format



tabs
Small extensions at the top of a dialog box; they look like tabs on a file folder; clicking one changes to a 
different section of the dialog, allowing access to other options.



task bar
The area of Windows along the bottom of the screen. This displays various information about Windows' 
status, such as the clock in the lower right corner. Also shown in the bar are the buttons representing 
open programs, such as IrfanView. If you minimize a program, you remove it from the screen, but leave it 
active. Only its button shows, until you click the button to restore it.



TGA
Truevision Advanced Raster Graphics Adapter (TARGA): Format by Truevision, Inc, used to support 
image capturing; used with a series of high-resolution graphics adaptors released under the TARGA 
name.



thumbnail
A small version of a larger image. Thumbnails are used as "stand-ins" for images where space is a 
problem. Example: pages on the WWW often use thumbnails to represent images stored at the website. 
The thumbnails take a fraction of the time to load that the large images would take. Usually, the thumbnail
is linked to the large image, so that a click on it will load the full-sized version.



TIF
Tagged Image File Format: a widely used raster format, jointly supported by Aldus; used mostly in 
desktop publishing; can be viewed on both Macs and PCs; this is the format used by most fax machines.



TIFF
Tagged Image File Format: a widely used raster format, jointly supported by Aldus; used mostly in 
desktop publishing; can be viewed on both Macs and PCs; this is the format used by most fax machines.



TIFF/TIF
Tagged Image File Format: a widely used raster format, jointly supported by Aldus; used mostly in 
desktop publishing; can be viewed on both Macs and PCs; this is the format used by most fax machines.



transparent color
One color in an image that does not show onscreen. This is most often used to allow an image 
background to be invisible against other colors. An example would be a company logo used on an 
internet web page; a transparent background color would allow it to be placed directly over other images 
on the page, and all will still be visible.



WAV
Windows audio file; they take up a lot of space, but can serve as a go-between for converting between 
some of the other sound formats.



WBMP
WAP Bitmap format



Windows Clipboard
An area used by Windows to store various file information for cut/copy/paste operations. For programs 
that support the clipboard (most do,) you can cut or copy from one application, and paste into another. An
example: an image edited pixel-by-pixel in Windows Paint can be copied to the clipboard, then pasted 
into IrfanView, from which it can be saved in a variety of formats. (Paint only saves as bmp.) Each time 
you cut or copy to the clipboard, it replaces whatever was there before.



WMF
Windows MetaFile format; Microsoft vector graphics file, more compact and portable than bmp images.



XBM
X11 Bitmap



XPM
X11 Pixmap






